Knowledgebase
mailenable authentication issue on pop3
Posted by Wolf on 02 October 2009 10:15 AM
----important see bottom for client recommendation ----

I think that this is closely related to the blackberry issue. I asked Jason if he ran a blackberry and the answer is yes. So what happens is that mailenable only allows 1 pop at a time. So since blackberry pops every 15 minutes or so and his outlook pops every 5 minutes then certain times during the day his pops clash!

There is a setting in mailenable under the pop properties - advanced that allows concurrent mailbox access. I have enabled this (and explained to client we may have to revert if it causes problems with syncing of mailboxes) and also on the general tab I have increased the server wide maximum concurrent connections from 16 to 25 (16 seems really low). Going to look at what Mela is set to as I am strongly thinking this is the blackberry issue. Will see if I can create a private knowledgebase article for this one.

Below is some more information from mailenable support article:
ME020018 - INF: What is the "templock" file in the mailbox directory?


SUMMARY

The templock file is created when a user logs into their email account via POP (i.e. when a user is retrieving email with a mail client). The lock file is to stop more than one person logging into the account at once. It is removed when the user disconnects.

DETAIL

If the user disconnects incorrectly (network error or they do not send the POP QUIT command), then this file may stay in the directory for about 10 minutes (by default). This is actually the timeout value for POP inactivity. This can be changed in POP properties via the Administration application. To remove the file without waiting for a timeout, restart the POP service. If a client is regularly getting this message, check the POP Debug logs and see whether the client has configured more than one email client to poll the server.

With versions 1.72 and later of MailEnable Standard, and versions 1.15 or later of Professional, it is possible to stop MailEnable from using this file. This will allow multiple users to connect to the one mailbox, though it may produce error messages in various email clients (if they try to access a message that has been deleted by another connection).

To enable this, set the following registry key:

[HKEY_LOCAL_MACHINE\SOFTWARE\Mail Enable\Mail Enable\Services\POP]
"Concurrent Access Enabled"= dword:00000001

If the registry key does not exist, then this registry value will need to be created.

MORE INFORMATION

Email client times out when downloading email via POP3: Article ME020285

POP Connector has high CPU utilization: Article ME020299


Here is relevant information from blackberry forum:
IMAP IDLE

Doc ID : KB13816
Last Modified : 2007-07-25
Document Type : Support

Environment
BlackBerry® Internet Service 2.x
Internet Message Access Protocol (IMAP) IDLE enabled email accounts
Note: To determine which version of the BlackBerry Internet Service you are using, see KB04989.

Problem

An IMAP IDLE connection is established with a messaging server is not allowing access from an email application (such as Microsoft® Outlook®) or from the IMAP integration in the BlackBerry Internet Service account.

This may cause the mailbox to be unavailable to the BlackBerry device user's email application or to the BlackBerry device, because concurrent connections to the BlackBerry device user's mailbox are not enabled on the IMAP messaging server.

If delays of 6 hours are noted when receiving email messages on the BlackBerry device, see KB13846.

Cause

If the messaging server supports the IMAP IDLE feature, the BlackBerry Internet Service will utilize this feature and attempt to maintain a persistent IMAP connection with the messaging server. If the messaging server does not allow concurrent connections to the BlackBerry device user's mailbox, this persistent IMAP connection may block additional Post Office Protocol (POP) or IMAP connections.

Resolution

Note: To update the BlackBerry device user's integration information after one of the following options is configured, the email account must be removed and reintegrated into the BlackBerry Internet Service account. For instructions, see KB02189.

The administrator of the IMAP messaging server must perform the steps outlined below. If you are unsure who administers your messaging server, please contact the BlackBerry Technical Support team for assistance.

Resolution 1

Configure the messaging server to permit concurrent connections to the BlackBerry device user's mailbox.

Resolution 2

Disable the IMAP IDLE feature on the messaging server.

Resolution 3

If POP access is available for the BlackBerry device user's mailbox, disable IMAP access on the messaging server. Removing and reintegrating the email account within the BlackBerry Internet Service account will change the integration type to the next available protocol.

Additional Information

IMAP is a protocol used for accessing email messages on a messaging server. The IMAP IDLE command is a widely implemented extension of the IMAP protocol that facilitates real-time email message delivery.

IMAP IDLE allows real-time email message delivery to a BlackBerry device by maintaining a persistent connection between the BlackBerry Internet Service and the email messaging server. Using this persistent connection, the messaging server will notify the BlackBerry Internet Service when new email messages arrive. When the BlackBerry Internet Service is notified by the messaging server that new email messages have arrived, it will connect to the messaging server and retrieve the new email message(s) and deliver them to the BlackBerry device. The benefit of this feature is real-time delivery of IMAP email messages to the BlackBerry device. The impact to the messaging server is low, as IMAP IDLE makes efficient use of messaging server bandwidth.

For more detailed information regarding the IMAP IDLE command, refer to RFC 2177.


And some more from mailenable forum______________________________----------------------------------
Bell Mobility could be right if you have configured the same account in your outlook as POP and in your BB as IMAP.

So, if you have that ONE account and want to receive one copy in your outlook and BB, then you should configure outlook to leave a copy in the server. Or in a better and easier way, you could just configure as IMAP your outlook and BB. That way it works even better.

If you have two accounts (2 different users or email addresses) configured one on each email client (outlook and BB), then you can ignore all the above explanation.


Make sure that your settings on BB are always honoring MailEnable.
For example, on your Email Reconciliation settings, make sure that the option ON CONFLICTS is set as "mailbox wins".

---client recommendation----
Clients should set their outlook to use imap instead of pop 3, imap has better support for concurrent mailbox access & avoids syncronization issues. Will post a knowledgebase article on this.
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